
Workshop Tutorial 
KaleidaGraph

This tutorial is intended for use by students wishing to 
visually analyze data sets. 

Workshop Description:
This tutorial will inform the user how to create and format 
graphs using KaleidaGraph. This program is useful for creating 
clear, legible figures to include in research papers and other 
professional documents. 

Suggested Reading and Related Links: 

http://lime.weeg.uiowa.edu/~c004135/kaleidahandout.html

http://www.google.com/search?hl=en&q=kaleidagraph+tutorial&
btnG=Google+Search
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KaleidaGraph Workshop –  

(from KaleidaGraph manual®- more about KaleidaGraph can be found in the manual) 

A guide through the operation of KaleidaGraph. The workshop will walk you thought the 

following:

• Create a new data set, change the column titles and format, sort the data, and calculate simple 

statistics

for the data. 

• Create a Scatter plot, change the display of the variable, use a few plot tools, and add a curve fit 

and error 

bars.

• Create a Column plot from a saved data set, modify the axes, change the display of the axis 

labels, and 

add value labels above the columns. 

• Display the plots from the preceding examples on the same page using the layout window. 

Some optional examples are also included to show you how to perform common operations not 

covered in the 

main examples. The topics include editing the legend text and frame, using Formula Entry, 

applying a userdefined 

curve fit, and modifying data in a saved plot. 

Generating a Sample Data Set 

This example takes you through the process of typing data into the data window, changing the 

column titles 

and format, sorting the data, and calculating statistics on the raw data. 

1.1.1 Entering Data 
The first step is to type some data into the data window. To do this: 

1. Type 4.3 into the first cell of column 0. 

2. Press the Enter (Windows), Return (Macintosh), or Down Arrow key to move down to the 

next

cell.

3. Type the values 2.9, 4.8, 3.2, 3.9, 3.5, and 2.3 into column 0. After each value is entered, press 

the

Enter, Return, or Down Arrow key to move down a row. 

4. Click the cell at row 0, column 1. 

5. Use the same method to type the data values 8.0, 6.2, 9.0, 5.7, 8.8, 7.2, and 4.9 into column 1. 
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1.1.2 Changing Column Titles and Format 
Next we will use the Column Format dialog to change the titles and format for these two 

columns. 

Workshop Title 2
Author

Date



1. Double-click the column title of column 0 (or choose Data > Column Format).

2. Type Time into the field below the listing of column titles. 

3. Click the name of the second column (B).

4. Type Test 1 into the field below the listing of column titles. 

This dialog can also be used to change the format of the data columns. The following steps 

change the display 

of the data so that each value only has one decimal place. 

1. Click Time, press Shift, and click Test 1. Both of these entries should be highlighted. 

2. From the Format pop-up menu, choose Fixed.

3. From the Decimals pop-up menu, choose 1.

4. Click OK to apply the changes to the data window. 

Your data window should resemble the one shown in Figure 2-1. 

Figure 2-1 Sample data window 

1.1.3 Sorting the Data 
Now we will sort the data to get the values in ascending order (from low to high). 

1. If it is not already selected, click the Time label in the data window to select the entire 

column. 

2. Choose Functions > Ascending Sort.

3. Press Shift and click both the Time and Test 1 entries. 

4. Click OK to apply the changes to the data window. 
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1.1.4 Calculating Statistics 
The final step is to calculate a number of standard statistics on one of the data columns. 

1. Click the Test 1 label in the data window to select the entire column. 

2. Choose Functions > Statistics to display the statistics for the Test 1 data. The Statistics dialog 

provides a Copy to Clipboard button to export the results for use in a data, plot, or layout 

window

3. Click OK.

At this point, you can proceed to the next example or save your data by choosing File > Save

Data.

1.2.2 Creating and Editing a Scatter Plot 
This example uses the data from the preceding example to create a Scatter plot. This example 

shows how to 
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change the marker type, size, and color, use the Identify and Data Selection tools, apply a Linear 

curve fit, 

display the curve fit equation, and add error bars. 

1.2.1 Creating a Scatter Plot 
Now, let’s create a plot using the example data entered in the previous exercise. 

1. Choose Gallery > Linear > Scatter. The Variable Selection dialog is displayed. Notice that 

the

name of the data file and its column titles are displayed in this dialog. 

2. Select Time as the X variable and Test 1 as the Y variable by clicking the appropriate buttons. 

Figure 2-2 shows what the Variable Selection dialog should look like at this point. 

Figure 2-2 Variable Selection dialog 

3. Click New Plot to create a Scatter plot. 
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The X variable you selected is the independent variable and the Y variable is the dependent 

variable. By 

default, the X variable is plotted on the horizontal axis and the Y variable is plotted on the 

vertical axis. 

The title of the plot is taken from the name of the data window. The X and Y axis titles are taken 

from the 

column titles of the variables being plotted. The Y variable title is also used in the legend. 

1.2.2 Changing Plot Style 
Now that the graph has been created, it can be modified very easily. For example, let’s change 

how the data 

is represented on the plot. You will use the Plot Style dialog to change the marker type, size, and 

color.

1. Triple-click the marker displayed in the legend (or choose Plot > Plot Style).

2. Select a different marker to represent the variable on the plot. The markers are displayed on 

the left 

side of the dialog. The first six markers in the left column are transparent; all of the others are 

opaque

3. Change the value in the Marker Size field to 18 and select a different color from the color 

palette.

4. Click OK and the plot is redrawn to reflect the changes that have been made. 
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1.2.3 Using the Identify Tool 

Now we will use the Identify tool (    ) on the toolbox to display the coordinates of the data. 

1. Select the Identify tool by either clicking it or pressing I on your keyboard. 

2. Once the tool is selected, click one of the data points. The X and Y coordinates are displayed 

in the 

upper-left corner of the plot window. 

It is also possible to leave the coordinates directly on the plot. To do this: 

• Press Alt (Windows) or Option (Macintosh) as you release the mouse button. This places a 

label

containing the coordinates to the right of the point. 

1.2.4 Applying a Linear Curve Fit 
You can quickly and easily fit a curve to a set of data points. To add a curve fit to the plot: 

1. Choose Curve Fit > Linear. This displays a dialog to select which variables to fit with the 

Least

Squares Error method. 

2. Select a variable to be fit (in this case Test 1) by clicking its check box. 

3. Click OK. The curve fit is calculated and the curve fit line is drawn on the plot. By default, the 

curve

fit results will also be displayed on the plot. If the equation is not displayed, turn on Display

Equation in the Plot menu. 

The position of the equation can be changed using the Selection Arrow. 

1. Click the Selection Arrow on the toolbox. 

2. Drag the equation to a new position. 

3. When the move is complete, click anywhere else in the window and the object handles 

disappear.

4. You can use the same technique to move the legend. 
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At this point, your plot should resemble Figure 2-3. 

Figure 2-3 Sample Scatter plot 
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1.2.5 Exporting the Results of the Curve Fit 
Once a curve fit is applied, you can copy the values of the curve fit line to the data window. 

These values are 

appended after the existing data in your data window. The first column will be a series of X 

values. The 

number of X values will be equal to the number of curve fit points specified in the Curve Fit 

Options dialog 

(Format menu). The second column will contain the values from the curve fit at each of these 

locations.

1. Reselect Linear from the Curve Fit menu. A Curve Fit Selections dialog appears with a drop-

down

arrow under View.

2. Click the drop-down arrow and choose Copy Curve Fit to Data Window from the pop-up 

menu. 

3. Click OK to return to the plot window. 

1.2.6 Using the Data Selection Tool 
Now we will use the Data Selection tool ( ) to graphically remove a point from the plot. The Data 

Selection

tool operates by enclosing a region of the plot in a polygon. Any data points outside the polygon 

are removed 

from the plot. By pressing Alt (Windows) or Option (Macintosh) as you make the polygon, the 

data inside 

the polygon can be eliminated. 

1. Select the Data Selection tool by either clicking it or pressing S on your keyboard. 

2. Once the tool is selected, press Alt (Windows) or Option (Macintosh) and create a polygon 

around

the data point in the lower-left corner of the plot window. Once the polygon is complete, the 

point is 

removed and the curve fit is recalculated. 

3. Double-click the Data Selection tool to return the plot to its original state. 

1.2.7 Adding Error Bars
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The last modification to the plot will be the addition of error bars. Error bars enable you to 

illustrate the amount 

of error for the plotted data. 

1. Choose Plot > Error Bars to display the Error Bar Variables dialog. 

2. Click the check box in the Y Err column to add vertical error bars. The Error Bar Settings 

dialog is 

displayed to choose the type of error. 

3. From the pop-up menu, choose Standard Error for the error type. The dialog should look 

like the 

one in Figure 2-4. 

Figure 2-4 Error Bar Settings dialog 

4. Click OK to return to the Error Bar Selection dialog. 

5. Click Plot to add the error bars to the plot. The error bars represent the standard error of the 

entire

data column. 

The finished plot is shown in Figure 2-5. 
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Figure 2-5 Finished Scatter plot 

You have just created a customized plot. You can continue on to the next example or you can 

save the plot by 

choosing File > Save Graph. If you save the graph, a copy of the data window is saved with the 

plot (in the 

same file). The process of opening a saved plot and extracting the data is covered in Section 

2.5.4.
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1.2.3 Creating and Editing a Column Plot 
This example uses a Column plot to show how to adjust major and minor ticks, axis labels, fill 

patterns, 

column spacing, plot color, and label rotation, in addition to displaying values above the 

columns. 

1.3.1 Opening a Saved Data File 
We will begin this example by opening a saved data set. 

1. Choose File > Open.

2. Locate and open the Data folder, which is located in the Examples folder.

3. Double-click the Housing Starts file. 

1.3.2 Creating a Column Plot 
Now, let’s create a plot using this data. 

1. Choose Gallery > Bar > Column. The Variable Selection dialog is displayed. 

2. Select Month as the X variable and 1966(K) as the Y variable by clicking the appropriate 

buttons.

3. Click New Plot to create a Column plot. 

1.3.3 Changing Axis Options
The first set of changes will be made in the Axis Options dialog. This dialog contains the 

majority of the 

settings for the axes, grid lines, tick marks, and axis labels. 

The first change is to remove the vertical grid lines. 

1. Triple-click the X axis (or choose Plot > Axis Options) to display the dialog in Figure 2-6. 

Figure 2-6 Axis Options dialog 
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2. Click Grids. The dialog changes to show the options that can be selected for the major and 

minor 

grids.

3. Choose None from the pop-up menu to the right of Major.

The next change is to remove the tick marks on the X axis. 

1. Click Ticks. The dialog changes to show the options that can be selected for the major and 

minor 

ticks.

2. Choose None from the pop-up menus below both Major and Minor.

The next change also involves the tick marks, but this time on the Y axis. 

1. Select the Y axis from the pop-up menu under Axis.

2. Choose Out from the pop-up menus below both Major and Minor.
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The last step is to change the maximum Y axis limit from 140 to 160. 

1. Click Limits. The dialog changes to show the options that can be selected for the limits. 

2. Change the value in the Max field from 140 to 160. 

3. Click OK to update the plot with all of the changes that were made while in the Axis Options 

dialog

1.3.4 Changing the Fill Pattern
Now you can change the fill pattern for the columns using the Plot Style dialog. 

1. Triple-click the small square in the legend which is filled with the same pattern as the columns 

(or

choose Plot > Plot Style).
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2. You can now select a different fill pattern for the columns. Click one of the fill patterns and a 

frame 

appears around that pattern to show that it is selected. 

3. Click OK.

1.3.5 Increasing the Column Offset
The next step is to increase the amount of space between the columns. 

1. Choose Format > Plot Extras.

2. Change the Column Offset percentage from 20 to 40%. 

3. Click OK to update the plot. 

At this point, your plot should resemble the one shown in Figure 2-7. 

Figure 2-7 Sample Column plot 

1.3.6 Changing Plot Color 
The next step is to add some color to the interior of the plot. By default, plots are created without 

interior and 

background colors. To select an interior color: 

1. Click any of the four axes to select the plot. Two sets of icons are displayed at the bottom of 

the

toolbox. The first icon displays two overlapping rectangles which control the interior and 

background color of the plot. 

2. Click the rectangle in the foreground and select one of the lighter colors from the color palette 

that

appears. The selected color is used to fill the interior of the plot. 

1.3.7 Editing Text Labels
The following steps remove the X axis title, resize the Y axis title, and rotate the X axis labels. 
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1. Click the X axis title, Month, and press Backspace (Windows) or Delete (Macintosh).

2. Click the Y axis title, 1966 (K). Drag any one of the four object handles to increase the font 

size of 

the label. It is also possible to change the font size by double-clicking the text label. 

3. Double-click one of the X axis labels. Notice that this dialog has its own set of menus. 

4. Choose Format > 90 Degree Rotation.

5. Choose Format > Right Justify so that the rotated labels line up evenly. 

6. Click OK to return to the plot window. 

7. Drag one of the X axis labels closer to the axis. You can also use the arrow keys to move 

selected

objects one pixel at a time in the specified direction (10 pixels if you press Shift while using the 

arrow keys). 

1.3.8 Adding Value Labels 
The last step is to display the value of each column. To do this, turn on Add Values in the Plot

menu. The 

values are placed at the top of each column. The values can be moved as a group by dragging 

them to a new 

location.

The Column plot is now complete. 
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1.4 Laying out Plots for Printing
This example shows how to use the layout window to place the plots created in the previous 

examples on a 

single page. 

Note: The following steps assume the two plots from the previous examples are still available. If 

you saved 

the plots and quit before reaching this example, use the Open command (File menu) to open 

these

plots. If you do not have them any longer, you can open any two plots from the Plots folder in 

the

Examples folder. 

1.4.1 Placing Plots in the Layout 
To place plots into the layout window: 

1. Choose Windows > Show Layout > KG Layout. If no layout has been created previously, an 

empty 

layout window is displayed. 

2. Use the Select Plot command (Layout menu) to select the two plots that were created in the 

previous examples. At this point, do not worry about their overall placement. 

1.4.2 Arranging Plots in the Layout 
To arrange the plots in the layout window: 
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1. Choose Layout > Arrange Layout. The Arrange Layout dialog allows you to enter the 

number of 

rows and columns to divide the layout window into equal sections. 

2. The default settings (two rows and one column) are sufficient for this example, so click OK.

Notice

that the layout window is divided into two equal sections and the plots are automatically resized 

and

placed into these sections. 

1.4.3 Modifying and Exporting the Layout 
It is possible to display more than just plots in the layout window. The plot tools are available, 

enabling you 

to add text and other objects to the layout. Various graphic images can be imported into the 

layout window. 

Also, a background pattern and frame can be added to the layout using the Set Background 

command

(Layout menu). 

The following steps explain how to add a text label to the layout window: 

1. Select the Text tool (     ) from the toolbox. You can select this tool by either clicking it 

or pressing 

T on your keyboard. 

2. Click anywhere in the layout window. The Edit String dialog will appear. 

3. Enter some text into this dialog. KaleidaGraph supports fully-stylized text, so feel free to 

highlight

various portions of the text string you have entered and make changes to the font, font size, style, 

and

color. Any changes you make only affect the selected portion of the text string. 

4. Once you are finished making changes, click OK to add the text label to the layout window. 

You can 

move the label to a new position using either the Text tool or the Selection Arrow. 

5. You can now print the layout by choosing File > Print Layout.

6. Close the layout window by choosing File > Close.
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1.5.1 Editing the Legend 
This example shows how to edit the legend frame and text. The attributes of the legend frame are 

controlled

by the bottom three icons on the toolbox. The steps in this example use the last icon in the 

toolbox, which is 

divided into two sections: a Line Style icon on the left and a Line Width icon on the right. 

1. Open the Sample Plot file, which is located in the Plots folder in the Examples folder.

2. Click the legend to select it. 

3. From the toolbox, click the Line Width icon (the up and down arrows) and choose Hairline 

from the 
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pop-up menu. Notice that the legend frame changes from a shadow box to a hairline width line. 

4. Now click the Line Style icon (the one to the left of the up and down arrows) and select one of 

the

dashed lines from the pop-up menu. Notice that the line surrounding the legend now contains the 

dashed pattern you selected. 

5. Finally, choose None from the Line Style pop-up menu. This removes the legend frame 

completely 

Now we can edit the text inside the legend. 

1. Select the Text tool ( ) from the toolbox. You can select this tool by either clicking it or 

pressing

T on your keyboard. 

2. Double-click any of the three labels inside the legend. A dialog is displayed to modify the text. 

3. Delete the text in this dialog and type any information you like. Feel free to change the font, 

size,

and style as well. 

4. Click OK to return to the plot and see the change. 

The changes you made only affect this one label. If you use the Selection Arrow instead of the 

Text tool, you 

can change the attributes of all legend items at once. However, you cannot edit the text with the 

Selection

Arrow.
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